Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000226opensim[GRID] Asset Servicepublic2007-12-19 21:412008-02-08 08:13
Reporternebadon 
Assigned Tojustincc 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOperating SystemOperating System Version
Product Version 
Target VersionFixed in Version 
Summary0000226: Inventory No Longer loads if you upload more than 26-30 items.
DescriptionUploading More than 26-30 textures into your inventory prevents them from loading 100% or even loading at all. I have tested this method with Both Bulk upload and single item upload with same results, I then modified my MySQL inventory database and reduced my inventory to 20 items, and my inventory loads fine again. All this testing was done with Standard SL client with SVN 2760. These tests were only performed in Grid Mode on Linux Machine running Mono 1.2.5.1 with MySQL 5.0.45 the UGAI and Sim and MySQL were all on the same machine.
TagsNo tags attached.
Git Revision or version number
Run Mode
Physics Engine
Script Engine
Environment
Mono Version
Viewer
Attached Filestxt file icon log_with_20_textures.txt [^] (32,105 bytes) 2007-12-22 21:45 [Show Content]
txt file icon log_with_30_textures.txt [^] (12,517 bytes) 2007-12-22 21:45 [Show Content]
log file icon region-console_20_textures.log [^] (183,328 bytes) 2007-12-23 07:12
log file icon region-console_30_textures.log [^] (126,086 bytes) 2007-12-23 07:12
log file icon opengrid-inventory-console_20_textures.log [^] (1,163 bytes) 2007-12-23 07:12
log file icon opengrid-inventory-console_30_textures.log [^] (1,163 bytes) 2007-12-23 07:12

- Relationships

-  Notes
(0000231)
justincc (administrator)
2007-12-21 17:53

At the present time I can get up to 35 textures in the texture folder on osgrid r2796 without any inventory problems. Admittedly, sometimes these textures have failed to upload (come up as 0x0), but this is almost certainly an issue unrelated to inventory. Please could you confirm whether you still have the problem with this revision using a fresh avatar (or a wiped inventory).
(0000232)
nebadon (administrator)
2007-12-21 18:08

yes the problem still exists, have you tried clearing you cache and relogging?
(0000244)
justincc (administrator)
2007-12-22 19:14
edited on: 2007-12-22 19:25

Okay, in order to pin this down further I have added some inventory debugging messages to the code. Specifically, I've added a line which will appear saying something like

[INVENTORY] [12-23 01:39:58] Received inventory response for user 2ae01317-9776-4a91-bbc9-26aaba28f4b4 containing 11 folders and 52 items

Please could you tell me what this line shows before and after your inventory failure.

However, I suspect this won't prove to be your problem. So what I also need is a dump of all the InventoryDescendents and FetchInventoryDescendents packets flowing between your client and opensim when you attempt to open the textures inventory folder. This can be achieved using SLProxy, which is part of the libsecondlife project. In case you haven't used it before, inaccurate instructions on how to set it up are here

http://www.libsecondlife.org/wiki/SLProxy [^]

Once its built you can run it on your machine using the command line

SLProxyMain.exe --proxy-remote-login-uri=http://192.168.1.2:9000 [^]

where proxy-remote-login-uri is the opensim uri. The default port to connect the client to is now http://127.0.0.1:8080 [^] to go through the proxy. Then from within the client, you need to chat the lines

/log InventoryDescendents
/log FetchInventoryDescendents

to start recording the inventory packets before opening the textures folder.

Please could you capture packet data with 25 textures and then 26 textures. This data will be essential for figuring out what the problem is.

(0000245)
nebadon (administrator)
2007-12-22 20:46

as for part 1 of your requirements, i have tried 3 times and never once have i seen "Received inventory response for user" come up on any of the server consoles.. I just wanted to note this before moving on to part 2 of the test.
(0000246)
nebadon (administrator)
2007-12-22 21:47

I attached 2 text files with the logs from the 2nd part of the test, one with 20 textures where the textures appear in the inventory folder and also load upon double click of the inventory item, and a 2nd with 30 textures where the textures do not even appear in inventory, both tests were done using the same account the 30 texture test was done 1st then i removed 10 textures from my inventoryitems table in MySQL to 20 items and the subsequent inventory then loaded.
(0000248)
justincc (administrator)
2007-12-23 02:46

The part 1 log messages were only added in r2808. Are you running this version? The messages will appear in the region console.
(0000249)
nebadon (administrator)
2007-12-23 02:55

yes i fully updated to most current revision before performing the tests.
(0000250)
justincc (administrator)
2007-12-23 02:59

In that case, please could you attach both your region and inventory server logs, preferably only those runs which are associated with the tests.
(0000251)
nebadon (administrator)
2007-12-23 03:29

ok logs have been attached.
(0000252)
justincc (administrator)
2007-12-23 03:51

Unfortunately your logs contain none of the verbose level messages. Please could you make sure verbose = True in your OpenSim.ini and re-run the tests. If verbose mode is on you should see noticeably more messages in the logs. Also, I want to confirm that the region log you are posting is the one into which you're logging in.

Could you also upgrade to the latest code level since it contains a few extra inventory error messages.
(0000255)
nebadon (administrator)
2007-12-23 07:13
edited on: 2007-12-23 07:17

Ok I uploaded new logs with Verbose enabled and new SVN updates installed. and yes these logs are from the server i am logging into, the UGAI and SIM are all on the same machine.

(0000256)
justincc (administrator)
2007-12-23 19:49

I've made a change to in r2813 to constrain the maximum inventory items in any single InventoryDescendents packet to 20 (which we know you can already receive). From the data you've provided me it appears that InventoryDescendents packets are still being correctly generated in the 30 items case, but for some reason the client is never receiving them. The maximum UDP packet size is 64k, but other things in the network (e.g. firewalls) may be constraining this.

So please could you update to r2813 and test. If r2813 does work, please could you feedback whether you have a maximum UDP packet size constraint somewhere in your network. If you do, you will very probably want to lift it since other OpenSim functionality could generate packets in excess of this size.

If this fix doesn't work, please could you capture the slproxy 20 and 30 packet cases again, along with the region console logs (it turns out the inventory console logs aren't important here). Please could you attach these in addition to the previous logs.
(0000257)
justincc (administrator)
2007-12-23 20:07

Nebadon reports that this change has fixed the issue, in both this case and in the separate case of loading entries for the library textures (after server restarts). He isn't running firewalls and is using mono 1.2.5.1 (same as OSGrid) on Debian 4 Lenny. But reducing the InventoryDescendents UDP packet size has definitely resolved the issue, and in other situations this problem had not occurred (such as my single machine mono 1.2.4 Ubuntu Gutsy Gibbon MySQL server setup with a separate Windows Second Life client), so something must be constraining the UDP packet size somewhere...

- Issue History
Date Modified Username Field Change
2007-12-19 21:41 nebadon New Issue
2007-12-21 17:53 justincc Note Added: 0000231
2007-12-21 17:53 justincc Status new => feedback
2007-12-21 18:08 nebadon Note Added: 0000232
2007-12-22 19:14 justincc Note Added: 0000244
2007-12-22 19:25 justincc Note Edited: 0000244
2007-12-22 20:46 nebadon Note Added: 0000245
2007-12-22 21:45 nebadon File Added: log_with_20_textures.txt
2007-12-22 21:45 nebadon File Added: log_with_30_textures.txt
2007-12-22 21:47 nebadon Note Added: 0000246
2007-12-23 02:46 justincc Note Added: 0000248
2007-12-23 02:55 nebadon Note Added: 0000249
2007-12-23 02:59 justincc Note Added: 0000250
2007-12-23 03:16 nebadon File Added: inventory_log_20_textures.txt
2007-12-23 03:17 nebadon File Added: inventory_log_30_textures.txt
2007-12-23 03:29 nebadon File Added: region_log_20_textures.txt
2007-12-23 03:29 nebadon File Added: region_log_30_textures.txt
2007-12-23 03:29 nebadon Note Added: 0000251
2007-12-23 03:51 justincc Note Added: 0000252
2007-12-23 07:11 nebadon File Deleted: inventory_log_20_textures.txt
2007-12-23 07:11 nebadon File Deleted: inventory_log_30_textures.txt
2007-12-23 07:11 nebadon File Deleted: region_log_20_textures.txt
2007-12-23 07:11 nebadon File Deleted: region_log_30_textures.txt
2007-12-23 07:12 nebadon File Added: region-console_20_textures.log
2007-12-23 07:12 nebadon File Added: region-console_30_textures.log
2007-12-23 07:12 nebadon File Added: opengrid-inventory-console_20_textures.log
2007-12-23 07:12 nebadon File Added: opengrid-inventory-console_30_textures.log
2007-12-23 07:13 nebadon Note Added: 0000255
2007-12-23 07:17 nebadon Note Edited: 0000255
2007-12-23 19:49 justincc Note Added: 0000256
2007-12-23 20:07 justincc Status feedback => resolved
2007-12-23 20:07 justincc Resolution open => fixed
2007-12-23 20:07 justincc Assigned To => justincc
2007-12-23 20:07 justincc Note Added: 0000257
2008-02-08 08:13 sdague Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker