Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002088opensim[REGION] Scripting Enginepublic2008-08-31 03:282008-10-11 09:15
ReporterUrsula Matova 
Assigned Tocfk 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDedibox Via C7OSLinux Ubuntu 8.0.4TLS 32 BitsOS Version-
Product Version 
Target VersionFixed in Version 
Summary0002088: As of svn.6045 - DotNetEngine Script Errors ( cannot compile )
DescriptionIf I can remember, from svn.6045 to current ( 6070 ) cannot script anymore.

Even with DotNetEngine / New XEngine, when I try to compile a very basic LSL script, I get this error :

Primitive: Error compiling script:*
Unknown chat: .

I have checked everything, and my config seems ok.

Anyone experienced this error ?
Any workarround ?
Did I missed important change ?

Regards.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux32
Mono Version
Viewer
Attached Files

- Relationships
related to 0002015closed Crossing from a Region to another is broken. 

-  Notes
(0004910)
Ursula Matova (reporter)
2008-08-31 03:30

On the Region console, don't get any error/warning :

12:29:25 - [ScriptEngine.DotNetEngine]: ScriptManager StartScript: localID: 720001, itemID: 10b90c20-541b-48a7-9232-8a15c17f7322
12:29:25 - [ScriptEngine.DotNetEngine]: Preparing to compile the following LSL to C# translated code
12:29:25 -
12:29:25 - using OpenSim.Region.ScriptEngine.Common; using System.Collections.Generic;
namespace SecondLife { public class Script : OpenSim.Region.ScriptEngine.Common.BuiltIn_Commands_BaseClass {
public Script() { }
        public void default_event_state_entry()
        {
            llSay(0, "Script running");
        }
        public void default_event_touch_start(LSL_Types.LSLInteger n)
        {
            llSay(0, "Touched !");
        }
} }

12:29:25 - [ScriptEngine.DotNetEngine]: Starting compile of "ScriptEngines/ScriptEngine.DotNetEngine_compiled_1091484892_3.dll".
12:29:26 - [SCRIPT]: Compiled assetID f68cde44-b6b3-4f69-aa83-5b215eb05e68: ScriptEngines/ScriptEngine.DotNetEngine_compiled_1091484892_3.dll
12:29:27 - [ScriptEngine.DotNetEngine]: AppDomain Loading: OpenSim.Region.ScriptEngine.Common, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null
12:29:27 - [ScriptEngine.DotNetEngine]: Loading into AppDomain: ScriptEngines/ScriptEngine.DotNetEngine_compiled_1091484892_3.dll
(0004946)
Ursula Matova (reporter)
2008-09-01 11:24

Solved by the workaround mentioned in mantis 0002015.
(0005551)
cfk (administrator)
2008-09-28 14:58

Since this was solved by the work around described, I'm going to resolve this. If this problem re-occurs, please either re-open or create a new Mantis.

- Issue History
Date Modified Username Field Change
2008-08-31 03:28 Ursula Matova New Issue
2008-08-31 03:28 Ursula Matova SVN Revision => 0
2008-08-31 03:28 Ursula Matova Run Mode => Grid (Multiple Regions per Sim)
2008-08-31 03:28 Ursula Matova Physics Engine => ODE
2008-08-31 03:28 Ursula Matova Environment => Mono / Linux32
2008-08-31 03:30 Ursula Matova Note Added: 0004910
2008-09-01 11:24 Ursula Matova Note Added: 0004946
2008-09-01 11:28 HomerHorwitz Relationship added related to 0002015
2008-09-28 14:58 cfk Status new => resolved
2008-09-28 14:58 cfk Resolution open => fixed
2008-09-28 14:58 cfk Assigned To => cfk
2008-09-28 14:58 cfk Note Added: 0005551
2008-10-11 09:15 cfk Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker