Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001209opensim[REGION] OpenSim Corepublic2008-05-09 12:012014-07-29 20:41
Reportermelanie 
Assigned Tomelanie 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001209: There are currently no constraints on link set size or prim count.
DescriptionOpenSim currently allows arbitrary-sized linksets, neither the link set size/distance rules, nor the max prim count is enforced.
In order to prevent 1500 prim hair, at least the 255 prims per linkset constraint needs to be added, with a maximum distance constraint possibly a configuration option.
TagsNo tags attached.
Git Revision or version number
Run Mode Grid (Multiple Regions per Sim)
Physics EngineODE
EnvironmentMono / Linux32
Mono VersionNone
Viewer
Attached Filespatch file icon link-limits.patch [^] (8,016 bytes) 2012-09-08 12:51 [Show Content]

- Relationships
child of 0002870new META - Linking issues 

-  Notes
(0001989)
sdague (administrator)
2008-05-09 12:04

If these limits get put in, they should be configurable in the OpenSim.ini, as I suspect people will want to adjust them differently on different environments.
(0001990)
middelink (reporter)
2008-05-09 12:24

actually, that gives rise to nice issues. What about my sim having a 1500 link-set limit, storing it in OSGrids asset server and taking it out (and/or edit it) in a region with a much lower setting? The unsuspecting user would quickly become aware of this mantis and post bugs :)
Hmm. perhaps the asset server should tell us the truth? and not the region?
(0001994)
mirceakitsune (reporter)
2008-05-09 13:27
edited on: 2008-05-09 13:28

Such limits shouldn't be in unless they can be configurable from opensim.ini. As long as every sim owner can configure them however, I guess they could work though I'm really not sure about this honestly. I mean as long as someone doesn't come dragging in 200 meters of prims or something like that, we are ok without such limits.

The reason is... I remember on the LL grid for example, people where having a really hard time creating larger vehicles such as spaceships because of these limits. Also there where big problems with linking bigger buildings together, which even I experienced and had to take larger buildings as groups in my inventory which wasn't really the best thing. So if anything like that would be to be implemented here too, it needs to be done with a lot of care.

If I am to support a distance limit between prims which can be linked together however, I would say nothing less then 60 meters at least. As for the number, at least 800 prims for people who make more complex things.

(0006384)
mirceakitsune (reporter)
2008-10-19 13:00

I'm setting this to resolved now since it's a pretty old discussion and we want to free the mantis, reopen if anyone wants to add more to this. Basically I don't believe this should be implemented because different sims can set this limit to something different and then entering with a linkset larger then X x Y x Z from one sim to another would not allow you to rez it?
(0006391)
melanie (administrator)
2008-10-19 14:05

It does need to be implemented. It is on my radar and I will do it when I get to it. Closed grids need it as a means to contol griefing and to prevent 1500 prim hair.
(0006392)
mirceakitsune (reporter)
2008-10-19 14:12

Well if it does need to be implemented it needs to be a grid opensim.ini setting then, and not an individual simulator setting. That's because as I mentioned in the note above, if someone makes a linkset with prims distanced to lets sat 30m between each other and takes it in inventory, what will they do if they want to use it on a sim where the limit is 20m? Be unable to rez it? That would cause a lot of annoying blocks I believe. Also if someone allows 50m linkset prims in their sim in standalone then puts that sim on a grid allowing only 25m, will that object be there "illegally" or delete when the region starts up, or refuse simulator startup..?
(0006394)
melanie (administrator)
2008-10-19 14:15

We have no gridwide settings, and no way, or intention, on forcing a setting on region operators.

My implementation will focus on the act of linking. Rezzing/wearing, moving, etc will be unaffected. I understand that this is not really usable in "open" grid. But there are closed grids, walled gardens, with homogenous settings, and those are the ones that need it and can make use of it.
(0006395)
mirceakitsune (reporter)
2008-10-19 14:18
edited on: 2008-10-19 14:19

In that case I can agree with such a setting if it only affects the building on a certain sim and not what you already own, it would be useful and not dangerous. Hope you can manage to implement this soon.

(0018921)
makopoppo (manager)
2011-07-16 05:03

Reminder sent to: justincc

just for reference
(0022548)
WhiteStar (reporter)
2012-09-08 13:00

I just noticed this and wish to pint out that it may cause issues for many folks. I have linksets with well over 255 prims, largest being 1700 prims, occupying a full std region. Forcing such an LL type limitation would undoubtedly break rezzing or creating of such linksets. Additionally, consider that OpenSim has full sized prims and so limiting distance rules which are calculated from the center of the prim will likely also introduce a variety of other issues.
(0022549)
SignpostMarv (reporter)
2012-09-08 13:02

Setting the config value to zero (the default) preserves the pre-patch behaviour of letting you have large linksets.
(0022550)
SignpostMarv (reporter)
2012-09-08 13:10

A few things my patch doesn't do:
1) prevent an existing linkset from being split in two where one or both new linksets would have a higher link count.
2) affect the max distance between any two prims in a linkset.
3) prevent the rezzing of high-prim linksets
(0022551)
WhiteStar (reporter)
2012-09-08 13:17

Thanks for the speedy response. If the config value is non-zero and avatar-X attempts to rez a linkset > 255 prims (LL viewer codebase limit, many TPV's are patched to eliminate) or one that does not comply with the std distance limits it should at minimum generate an error message to avatar-x and prevent rezzing altogether to preserve the content in the user inventory. Considering if the object in question is not copy/trans.
(0022560)
melanie (administrator)
2012-09-09 12:18

Applies with changes. Please base your patches on core, not on your own repo.

- Issue History
Date Modified Username Field Change
2008-05-09 12:01 melanie New Issue
2008-05-09 12:01 melanie SVN Revision => 0
2008-05-09 12:01 melanie Run Mode => Grid (Multiple Regions per Sim)
2008-05-09 12:01 melanie Physics Engine => ODE
2008-05-09 12:01 melanie Environment => Mono / Linux32
2008-05-09 12:04 sdague Note Added: 0001989
2008-05-09 12:24 middelink Note Added: 0001990
2008-05-09 13:27 mirceakitsune Note Added: 0001994
2008-05-09 13:28 mirceakitsune Note Edited: 0001994
2008-10-19 13:00 mirceakitsune Status new => resolved
2008-10-19 13:00 mirceakitsune Resolution open => fixed
2008-10-19 13:00 mirceakitsune Assigned To => mirceakitsune
2008-10-19 13:00 mirceakitsune Note Added: 0006384
2008-10-19 14:05 melanie Assigned To mirceakitsune =>
2008-10-19 14:05 melanie Status resolved => feedback
2008-10-19 14:05 melanie Resolution fixed => reopened
2008-10-19 14:05 melanie Note Added: 0006391
2008-10-19 14:06 melanie Status feedback => assigned
2008-10-19 14:06 melanie Assigned To => melanie
2008-10-19 14:12 mirceakitsune Note Added: 0006392
2008-10-19 14:15 melanie Note Added: 0006394
2008-10-19 14:18 mirceakitsune Note Added: 0006395
2008-10-19 14:19 mirceakitsune Note Edited: 0006395
2009-01-21 11:14 lbsa71 Relationship added child of 0002870
2011-07-16 05:03 makopoppo Note Added: 0018921
2012-09-08 12:51 SignpostMarv File Added: link-limits.patch
2012-09-08 12:51 SignpostMarv Status assigned => patch included
2012-09-08 13:00 WhiteStar Note Added: 0022548
2012-09-08 13:02 SignpostMarv Note Added: 0022549
2012-09-08 13:10 SignpostMarv Note Added: 0022550
2012-09-08 13:17 WhiteStar Note Added: 0022551
2012-09-09 12:18 melanie Mono Version => None
2012-09-09 12:18 melanie Note Added: 0022560
2012-09-09 12:18 melanie Status patch included => resolved
2012-09-09 12:18 melanie Resolution reopened => fixed
2014-07-29 20:41 chi11ken Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker