Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001127opensim[REGION] Scripting Enginepublic2008-05-03 10:062008-07-12 10:24
ReporterOlish 
Assigned Tocfk 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001127: HTTP_METHOD parameter does not work for POST requests
DescriptionHello !

I tried to pass parameters to a webpage through HTTP POST method but it does not work. Only with GET method.

Is it scheduled to be implemented already ? If no, will you implement it ?

Thanks a lot.
Regards,
Olish.

default
{
    
    state_entry()
    {
    
        llHTTPRequest("http://myserver.net/test.php?p=hello", [^] [HTTP_METHOD, "POST"], "");
        llSay(0, "Sent");
    
    }
    
    http_response(key id, integer s, list meta, string body)
    {
        
        llSay(0, body);
        // body is empty while it should say "hello"
        // it works with GET method not with POST
        
    }
    
}
TagsNo tags attached.
Git Revision or version number
Run ModeStandalone (1 Region)
Physics EngineODE
Environment.NET / Windows32
Mono Version
Viewer
Attached Filespatch file icon llHTTPRequestFixPOST.patch [^] (703 bytes) 2008-07-08 15:20 [Show Content]

- Relationships

-  Notes
(0001837)
Olish (reporter)
2008-05-03 10:08

HTTP requests are being sent as GET requests, even if the parameters specify a POST request, and the request body is specified. Applications that need POST support therefore can't be easily used. The full parameters for HTTP requests aren't necessarily crucial, but at least the ability to do POST requests is.
(0003573)
Grumly57 (reporter)
2008-07-08 15:22

The http method is set correctly. The problem came from the MIME type which was stuck to default because of a parameters parsing issue.
(0003603)
cfk (administrator)
2008-07-09 11:42

commit as r5400

- Issue History
Date Modified Username Field Change
2008-05-03 10:06 Olish New Issue
2008-05-03 10:06 Olish SVN Revision => 4378
2008-05-03 10:06 Olish Run Mode => Standalone (1 Region)
2008-05-03 10:06 Olish Physics Engine => ODE
2008-05-03 10:06 Olish Environment => .NET / Windows32
2008-05-03 10:08 Olish Note Added: 0001837
2008-07-08 15:20 Grumly57 File Added: llHTTPRequestFixPOST.patch
2008-07-08 15:22 Grumly57 Note Added: 0003573
2008-07-08 15:22 Grumly57 Status new => patch included
2008-07-09 11:42 cfk Status patch included => resolved
2008-07-09 11:42 cfk Resolution open => fixed
2008-07-09 11:42 cfk Assigned To => cfk
2008-07-09 11:42 cfk Note Added: 0003603
2008-07-12 10:24 cfk Status resolved => closed


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker