MantisBT - opensim
View Issue Details
0008522opensim[REGION] OpenSim Corepublic2019-04-25 01:162019-07-31 14:23
aiaustin 
 
lowtweakalways
newopen 
PCWindows10
master (dev code) 
master (dev code) 
Grid (Multiple Regions per Sim)
BulletSim
.NET / Windows64
None
N/A
0008522: MAP-uuid.png images location improvement
Currently visited region map images for the local grid with names in the form MAP-uuid.png are placed in the top level bin directory.

Can we tidy that up so they are placed in a specific directory? It could be hard wired under bin or be configurable as an OpenSim.ini parameter in the [Map] section perhaps?
Note that map tile images for HG visited regions are placed in a nominated directory via a parameter in config-include/GridCommon.ini or config-include/Standalone.ini

[GridService]
    ;; Directory for map tile images of linked regions
    MapTileDirectory = "./maptiles"
No tags attached.
related to 0008555new  MapTileDirectory location is not respected in config 
Issue History
2019-04-25 01:16aiaustinNew Issue
2019-04-25 02:08BillBlightNote Added: 0035166
2019-04-25 02:10BillBlightNote Edited: 0035166bug_revision_view_page.php?bugnote_id=35166#r8030
2019-04-25 02:15BillBlightNote Added: 0035167
2019-04-25 05:21mewtwo0641Note Added: 0035169
2019-04-25 05:39aiaustinNote Added: 0035170
2019-04-25 05:45aiaustinNote Edited: 0035170bug_revision_view_page.php?bugnote_id=35170#r8032
2019-04-25 08:01mewtwo0641Note Added: 0035171
2019-04-25 08:36Robert AdamsNote Added: 0035172
2019-07-04 07:46aiaustinRelationship addedrelated to 0008556
2019-07-04 07:46aiaustinRelationship deletedrelated to 0008556
2019-07-04 07:46aiaustinRelationship addedrelated to 0008555
2019-07-04 09:32tampaNote Added: 0035443
2019-07-31 14:23UbitUmarovNote Added: 0035527
2019-08-01 01:20aiaustinNote Edited: 0035527bug_revision_view_page.php?bugnote_id=35527#r8322

Notes
(0035166)
BillBlight   
2019-04-25 02:08   
(edited on: 2019-04-25 02:10)
Hmmm? What? ..

Not on any of my regions ... not sure why it is doing it to you


Ok I see one of those occasionally, I was thinking you meant a ton of them ..

(0035167)
BillBlight   
2019-04-25 02:15   
Oh, Yeah I guess this could be an issue if you are running a ton of sims in the same instance, (NOT ADVISED), guess need to poke Ubit ..
(0035169)
mewtwo0641   
2019-04-25 05:21   
Are you using Warp3D? Because I don't see this happen with the standard (old) map generator. I have however seen this happen with Warp3D maps.
(0035170)
aiaustin   
2019-04-25 05:39   
(edited on: 2019-04-25 05:45)
Yes, it is warp3D I am using, Maybe it just writes to the same directory the warp3d.dll is in (bin).

(0035171)
mewtwo0641   
2019-04-25 08:01   
Had a look in Warp3DImageModule.cs at the CreateMapTile() method and it does appear that the resulting images are just being saved at whatever directory is relative to the dll file which in this case would be directly in bin.

string filename = "MAP-" + m_scene.RegionInfo.RegionID.ToString() + ".png";
tile.Save(filename, ImageFormat.Png);

^ There is no specification for a directory for the images to go in the filename variable so it would end up in bin as far as I can tell.
(0035172)
Robert Adams   
2019-04-25 08:36   
It's time for someone to replace the Warp3D map creation module with one that uses Xenko.
(0035443)
tampa   
2019-07-04 09:32   
Lovely for you to volunteer to do that Robert, if you need help let us know :P

What would be the benefit of yet another mapping module though?

If it is done, it should be finally made as a kinda addon-module not stopping region startup as well!
(0035527)
UbitUmarov   
2019-07-31 14:23   
(edited on: 2019-08-01 01:20)
those were just warp3d debug files, that I still keep around in case I make more changes to warp3d rendering