MantisBT - opensim
View Issue Details
0008499opensim[REGION] OpenSim Corepublic2019-03-18 14:172019-03-28 21:41
Kayaker Magic 
 
normalmajoralways
acknowledgedopen 
Linux/Mono0.9.1.0 Snail DevUbuntu
0.9.0.1 
 
492ba8f644abf64704bcf35a4f3d3c7990833f00
Grid (1 Region per Sim)
ubODE
Mono / Linux64
5.x
any
0008499: Region restarts have become very slow
Updating to a very recent version of Snail Dev, I found that region restarts that used to take 2-3 minutes now take over an hour and the log is full of error messages that look like this:
[WARNING]: EOC marker not found. Codestream is corrupted.
01:18:45 - [SCENE]: Initializing script instances in Shoalwater Bay

Note that the EOC error does not have a time log.
The script cache was emptied before the restart.
The length of time for the restart to take seems correlated to the number of Codestream messages we see.
Build the latest version of Snail Dev (I did this with the March 15th version, our pervious version was from January). Restart a region.

No tags attached.
Issue History
2019-03-18 14:17Kayaker MagicNew Issue
2019-03-18 14:31BillBlightNote Added: 0034926
2019-03-18 18:58UbitUmarovNote Added: 0034931
2019-03-21 13:40Fly-Man-Note Added: 0034945
2019-03-21 13:40Fly-Man-Statusnew => acknowledged
2019-03-21 14:37BillBlightNote Added: 0034946
2019-03-28 21:41BillBlightNote Added: 0034996

Notes
(0034926)
BillBlight   
2019-03-18 14:31   
Are you using Warp3d? If so warp3d has become much more intensive, but the trade off is it does not leak memory like it used to ...
(0034931)
UbitUmarov   
2019-03-18 18:58   
if asset cache is empty all assets will need to be fetch from assets service.
depending on options warp3d (or other map) will fetch all to draw the map image.

- that can take a lot of time.
even will all assets in cache, warp3d is now a bit slower, because it does more things. Only running it ocasionally and using a fixed texture (that it can generate) maybe a option.

- if script cache is empty, they will fetched from grid and compiled.
that can take time (not as bad as warp3d)

those EOC errors are textures that did fail to decode.
(0034945)
Fly-Man-   
2019-03-21 13:40   
Cam confirm this happening with the new Warp3D
(0034946)
BillBlight   
2019-03-21 14:37   
Yep Ubit stated when he fixed the memory leak that it was going to be slower , but he also increased the quality of the images, and added other new features ...
(0034996)
BillBlight   
2019-03-28 21:41   
No additional information has been added to this ticket but,

After talking with the person where this error is happening, regions are taking well over an hour to start up ..

From the info given it does look like Warp3d, but personally have not seen regions take over an hour to start up.

It is possible that it is not Warp3d related, but without more information, cannot really say.

Please feel free to add to this ticket with some region statistics and startup times , ie number of prims and maybe a rough mesh count.