MantisBT - opensim
View Issue Details
0008492opensim[REGION] OpenSim Corepublic2019-02-26 12:352019-06-15 14:56
aiaustin 
 
normalminoralways
newopen 
PCWindows10
0.9.1.0 
0.9.1.0 
0.9.1 .0 824 fe46f8c (2019-02-26 15:09)
Grid (Multiple Regions per Sim)
BulletSim
.NET / Windows64
None
N/A
0008492: Vivox Voice Module - Working but giving [VivoxVoice] Create failed messages
Vivox voice does appear to be working on my grid (AiLand) regions but I am seeing a warning about "create failed" on the region UUID for each region.

2019-02-26 20:33:08,294 INFO [VivoxVoice] using vivox server www.osp.vivox.com
2019-02-26 20:33:08,294 DEBUG [VivoxVoice] Establishing admin connection
2019-02-26 20:33:08,591 INFO [VivoxVoice] Admin connection established
2019-02-26 20:33:08,591 INFO [VivoxVoice] plugin enabled

But I then see one of these messages for each region in the OpenSim.exe instance as they load...

2019-02-26 20:33:09,185 WARN [VivoxVoice] Create failed <*:46d2006b-4531-4f77-a2bb-f785d416ae03:AiLand>
No tags attached.
Issue History
2019-02-26 12:35aiaustinNew Issue
2019-02-26 12:41aiaustinNote Added: 0034865
2019-02-26 12:42BillBlightNote Added: 0034866
2019-02-26 12:43BillBlightNote Edited: 0034866bug_revision_view_page.php?bugnote_id=34866#r7857
2019-02-26 12:44BillBlightNote Added: 0034867
2019-02-26 12:50aiaustinDescription Updatedbug_revision_view_page.php?rev_id=7859#r7859
2019-02-26 12:52aiaustinSummaryVivox Voice Module - Workign but giving [VivoxVoice] Create failed messages => Vivox Voice Module - Working but giving [VivoxVoice] Create failed messages
2019-02-26 12:53aiaustinDescription Updatedbug_revision_view_page.php?rev_id=7860#r7860
2019-02-26 14:07aiaustinNote Added: 0034868
2019-02-27 00:53aiaustinNote Added: 0034872
2019-02-27 03:17aiaustinNote Edited: 0034872bug_revision_view_page.php?bugnote_id=34872#r7862
2019-02-27 03:47aiaustinNote Edited: 0034872bug_revision_view_page.php?bugnote_id=34872#r7863
2019-06-15 14:56cugarajalNote Added: 0035400

Notes
(0034865)
aiaustin   
2019-02-26 12:41   
Vivox OpenSim Support folks wondered if it might be a warning that the channel already exists. But I see it even on starting a freshly updated OpenSim setup.
(0034866)
BillBlight   
2019-02-26 12:42   
(edited on: 2019-02-26 12:43)
if you look at the top of your logs and as you posted you should see something like this much earlier ..

It may very well registering the region then ..


2019-02-26 19:01:59,578 INFO [VivoxVoice] using vivox server www.osp.vivox.com
2019-02-26 19:01:59,579 DEBUG [VivoxVoice] Establishing admin connection
2019-02-26 19:01:59,730 INFO [VivoxVoice] Admin connection established
2019-02-26 19:01:59,730 INFO [VivoxVoice] plugin enabled

(0034867)
BillBlight   
2019-02-26 12:44   
Vivox was changing some things, and it may be it is registering the region on the admin connection.
(0034868)
aiaustin   
2019-02-26 14:07   
Dylan Douglas (Vivox Support) on Feb 26, 4:09 PM EST wrote:
During the move, the backend was updated, so the default behavior of the channel when the server is terminated might have changed. I cannot speak to that, but if voice is working as expected, it would seem that the warning can be ignored.
(0034872)
aiaustin   
2019-02-27 00:53   
(edited on: 2019-02-27 03:47)
I wonder if the OpenSim server Vivox module code that is trying this create which fails is in a position to know the cause of the failure and note that in the log. If it is really the case that the channel already exists and the fault code/message indicates this that would be a better message to give in the log, rather than indicating a failure.

I notice also that when OpenSim.exe is stopped for each region I see a log message to say "Parent channel delete failed". So maybe there is some change of protocol for this.

[VivoxVoice] Parent channel delete failed Welcome:dbaf86ed-55bd-4be8-8c5b-9314f4d0fbce:

(0035400)
cugarajal   
2019-06-15 14:56   
Same exact problem here too, since approx Feb 2019. Disconcerting to see this on every startup and shutdown.

macOS 10.13.6 / Mono 5.20.1.x / latest OS in GIT

Agree with alaustin, Vivox module needs to be debugged to determine what's actually happening and if something is breaking.