MantisBT - opensim
View Issue Details
0008334opensim[MISC] Compiling / Buildingpublic2018-07-10 23:562018-07-11 00:55
DarkWof 
 
highminoralways
newopen 
DebianDebian
0.9.0.1 
 
opensim-0.9.0.1-392-gee115a8
Grid (1 Region per Sim)
ubODE
Mono / Linux64
5.x
0008334: Comailing crash
The MoneyModul causes the compilation to abort.
Upload & unpacking tar.gz
coping modules
./runprebuild.sh
xbuild
        /usr/lib/mono/xbuild/14.0/bin/Microsoft.Common.targets: warning : Reference 'Axiom.MathLib.dll' not resolved

/home/opensim-0.9.0.1-392-gee115a8/OpenSim.sln (default targets) ->
(Build target) ->
/home/opensim-0.9.0.1-392-gee115a8/addon-modules/OpenSim.Grid.MoneyServer/src/MoneyServer.csproj (default targets) ->
/usr/lib/mono/xbuild/14.0/bin/Microsoft.Common.targets (ResolveAssemblyReferences target) ->

        /usr/lib/mono/xbuild/14.0/bin/Microsoft.Common.targets: warning : Reference 'Axiom.MathLib.dll' not resolved

/home/opensim-0.9.0.1-392-gee115a8/OpenSim.sln (default targets) ->
(Build target) ->
/home/opensim-0.9.0.1-392-gee115a8/addon-modules/OpenSim.Grid.MoneyServer/src/MoneyServer.csproj (default targets) ->
/usr/lib/mono/xbuild/14.0/bin/Microsoft.CSharp.targets (CoreCompile target) ->

        CSC: warning CS2002: Source file 'obj/Debug/.NETFramework,Version=v4.0.AssemblyAttribute.cs' specified multiple times
        MoneyServerBase.cs(72,32): warning CS0649: Field 'MoneyServerBase.m_certVerify' is never assigned to, and will always have its default value null

Errors:

/home/opensim-0.9.0.1-392-gee115a8/OpenSim.sln (default targets) ->
(Build target) ->
/home/opensim-0.9.0.1-392-gee115a8/addon-modules/OpenSim.Grid.MoneyServer/src/MoneyServer.csproj (default targets) ->
/usr/lib/mono/xbuild/14.0/bin/Microsoft.CSharp.targets (CoreCompile target) ->

        MoneyServerBase.cs(148,25): error CS1729: 'BaseHttpServer' does not contain a constructor that takes 2 arguments

         5 Warning(s)
         1 Error(s)
No tags attached.
Issue History
2018-07-10 23:56DarkWofNew Issue
2018-07-11 00:31tampaNote Added: 0032758
2018-07-11 00:55BillBlightNote Added: 0032760

Notes
(0032758)
tampa   
2018-07-11 00:31   
There is something wrong with your build environment, there should not be these warnings with the current release code.

The error you are seeing is because the module is not compatible with the current code, you need to edit the module to make it compatible with its dependencies in the base code again, aka review the modules code and make sure the functions it implements use the correct parameters and types.

Use msbuild instead of xbuild, xbuild is being deprecated.
(0032760)
BillBlight   
2018-07-11 00:55   
The module is not compatible with the current code..
First thing I see is Axiom.MathLib.dll is no longer included with OpenSimulator