MantisBT - opensim
View Issue Details
0007945opensim[REGION] OpenSim Corepublic2016-06-28 09:342016-07-03 20:32
nebadon 
 
normalmajoralways
newopen 
 
 
Standalone (1 Region) , Grid (1 Region per Sim)
BulletSim
Mono / Linux32, Mono / Linux64, Mono / Windows, Mono / OSX, .NET / Windows32, .NET / Windows64
None
Singularity 1.8.7
0007945: Unable to add texture. Please wait a few seconds and try again (Singularity 1.8.7)
In the latest version of Singularity 1.8.7 and OpenSimulator as far back as 0.8 trying to apply a new texture to large linksets or multiple selected prims causes tons of popup box errors in the viewer. ie: "Unable to add texture. Please wait a few seconds and try again"

to recreate the problem rez out 48 cubes with default wood texture
select all 48 cubes and go the texture tab and click the texture select window, on the selector popup press the "Blank" button, you will be presented with 48 popup OK buttons with the error above displayed" what is strange though is that all of the boxes sides and bottom will be white, but the top side surface on all 48 objects remains the default wood texture. If you select just a single prim the same behavior does not occur.

After extensive testing in Second Life i can not trigger this bug in that grid, even with 768 cubes selected.
No tags attached.
png sing_texture_error_01.png (1,589,799) 2016-06-28 09:38
http://opensimulator.org/mantis/file_download.php?file_id=4559&type=bug
png sing_texture_error_02.png (2,040,894) 2016-06-28 09:39
http://opensimulator.org/mantis/file_download.php?file_id=4560&type=bug
Issue History
2016-06-28 09:34nebadonNew Issue
2016-06-28 09:35nebadonDescription Updatedbug_revision_view_page.php?rev_id=5628#r5628
2016-06-28 09:38nebadonFile Added: sing_texture_error_01.png
2016-06-28 09:39nebadonFile Added: sing_texture_error_02.png
2016-06-28 09:43nebadonNote Added: 0030820
2016-06-29 17:12DivaNote Added: 0030841
2016-06-29 17:18DivaNote Added: 0030842
2016-06-29 17:20DivaNote Added: 0030843
2016-06-29 17:44DivaNote Added: 0030844
2016-06-29 19:29kenvcNote Added: 0030845
2016-07-03 20:29Whirly FizzleNote Added: 0030862
2016-07-03 20:32Whirly FizzleNote Added: 0030863

Notes
(0030820)
nebadon   
2016-06-28 09:43   
quote from CmdrCupcake on #singularityviewer IRC
"<CmdrCupcake> mix of race condition and callback issues
<CmdrCupcake> shitty handling of task inventory on the simulator side(and opensim's is DEFINITELY shitty) can make it act up harder
(0030841)
Diva   
2016-06-29 17:12   
FYI this doesn't happen in Firestorm. Trying the new singu now.
(0030842)
Diva   
2016-06-29 17:18   
oh wow, this is really bad in the new singu.
I'm not sure I know where to start, given that this doesn't happen in FS or in the old Singu...
(0030843)
Diva   
2016-06-29 17:20   
Also, I noticed that even if the viewer already has the texture cached, the pop ups still happen. I suspect this is a viewer issue, not server issue.
(0030844)
Diva   
2016-06-29 17:44   
It doesn't happen all the time. I don't understand what makes it stop erring, but sometimes it stops erring. When it stops, it never starts again, it stays good. I've no idea where to even start diagnosing this!
(0030845)
kenvc   
2016-06-29 19:29   
Not sure if this is related, but... I was having so many issues with textures not rezing or taking a very long time to rez with Sing on high prim sims, I finally gave up and switched to FS. All texture issues went away.
(0030862)
Whirly Fizzle   
2016-07-03 20:29   
As far as I'm aware, this is a viewer bug.
Same bug happened on SL grids on Firestorm before the bug was fixed.

Please refer to these JIRA issues.
http://jira.phoenixviewer.com/browse/FIRE-15508 [^]
http://jira.phoenixviewer.com/browse/FIRE-16755 [^]
(0030863)
Whirly Fizzle   
2016-07-03 20:32   
Also see: http://bugs.inworldz.com/mantis/view.php?id=3012 [^]