MantisBT - opensim
View Issue Details
0007228opensim[REGION] OpenSim Corepublic2014-06-21 06:102017-11-15 21:48
Richardus Raymaker 
Robert Adams 
normalmajoralways
assignedopen 
 
 
0.8 release
Grid (1 Region per Sim)
BulletSim
.NET / Windows64
None
Singularity 1.8.5 (5617)
0007228: Var terrain loading (still) terrible slow.
I readed that it must be fixed. waited until 0.8 release for this to try.
But its still not fix, its loading slow from outside to the inner side.
added the following line in opensim.ini

[Terrain]
    SendTerrainUpdatesByViewDistance = true;

strange thing, its loading very fast on normal region, but not on the important variable region. thats not changed at all.

No tags attached.
Issue History
2014-06-21 06:10Richardus RaymakerNew Issue
2014-06-21 06:55danbannerNote Added: 0026325
2014-06-21 07:05Richardus RaymakerNote Added: 0026327
2014-06-21 07:17Robert AdamsNote Added: 0026328
2014-06-21 07:17Robert AdamsAssigned To => Robert Adams
2014-06-21 07:17Robert AdamsStatusnew => assigned
2014-06-21 07:36Richardus RaymakerNote Added: 0026332
2014-06-21 07:46Richardus RaymakerNote Edited: 0026332bug_revision_view_page.php?bugnote_id=26332#r2769
2014-06-23 08:16Garmin KawaguichiNote Added: 0026357
2014-06-23 08:18Garmin KawaguichiNote Edited: 0026357bug_revision_view_page.php?bugnote_id=26357#r2801
2017-11-15 21:48TomTheDragonNote Added: 0032441

Notes
(0026325)
danbanner   
2014-06-21 06:55   
You might want to use 'config show Terrain' in the console to see if that setting is actually being used. I have added this to my vars and they load terrain quickly
(0026327)
Richardus Raymaker   
2014-06-21 07:05   
console is saying, SendTerrainUpdatesByViewDistance = true;
but not see any difference compared to some version from april.
(0026328)
Robert Adams   
2014-06-21 07:17   
Is it possible you could use Fraps or similar and capture a video of the slow loading?
(0026332)
Richardus Raymaker   
2014-06-21 07:36   
(edited on: 2014-06-21 07:46)
Posting a video soon, noted one thing. when i login on the var. or teleport in for the first time its loading slow. the next time you teleport in its showing things fast.

Add: Here's the video. getting the idea that var region terrain need to be buffer at startup of the simulator, otherwise i could not explain why its loading fast the second time i go back to the region in one session. After relog its again slow for the first time. well slow...

https://www.youtube.com/watch?v=QgJ4uGMtG7A&feature=youtu.be [^]

(0026357)
Garmin Kawaguichi   
2014-06-23 08:16   
(edited on: 2014-06-23 08:18)
Using an extended minimap and a 1280x1280 varregion, it gives a better idea of the appearance of the terrain in a spiral fashion.

(0032441)
TomTheDragon   
2017-11-15 21:48   
I can confirm that this is still an issue in master.