MantisBT - opensim
View Issue Details
0007020opensim[REGION] OpenSim Corepublic2014-02-20 03:242014-12-02 01:07
aiaustin 
 
normalminoralways
newopen 
PCWindows8.1
master (dev code) 
 
Grid (Multiple Regions per Sim)
BulletSim
.NET / Windows64
None
N/A
0007020: OpenMetaverse Failed to decode mesh asset zlib.ZStreamException
2014-02-20 09:15:20,748 ERROR - OpenMetaverse Failed to decode mesh asset zlib.ZStreamException: inflating:
   at zlib.ZOutputStream.Write(Byte[] b1, Int32 off, Int32 len)
   at OpenMetaverse.Assets.AssetMesh.Decode()

2014-02-20 09:15:59,310 ERROR - OpenMetaverse Failed to decode mesh asset zlib.ZStreamException: inflating:
   at zlib.ZOutputStream.Write(Byte[] b1, Int32 off, Int32 len)
   at OpenMetaverse.Assets.AssetMesh.Decode()

This problem has arisen between the last OSGrid packaged region add on release we used...

OSgrid 0.8.0 (Dev) d466446: 2014-01-18
git hash : d466446df342a319b6d85f478c1ec873d3a6984c

and the most recent one installed...

OSgrid 0.8.0 (Dev) fc9930e: 2014-02-16
git hash : fc9930e420d4b8f9125754b8f0ee7d2c53eec592

Switching back to this earlier version with the identical data based and region setup makes the errors go away.

--------------------------

Another error related to BulletSim process taints messages has I believe been present in both versions.. but noted here in case its related. This is the only other Red error our OSGrid add on regions throws...

2014-02-20 09:16:07,217 ERROR - OpenSim.Region.Physics.BulletSPlugin.BSScene [BULLETS SCENE]: ProcessPostTaintTaints: BSLinksetCompound.ScheduleRebuild-1114667342: Exception: System.NullReferenceException: Object reference not set to an instance of an object.
   at OpenSim.Region.Physics.BulletSPlugin.BSAPIUnman.AddChildShapeToCompoundShape(BulletShape shape, BulletShape addShape, Vector3 pos, Quaternion rot) in k:\OSGRID\opensim-fc9930e\OpenSim\Region\Physics\BulletSPlugin\BSAPIUnman.cs:line 350
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<>c__DisplayClass3.<RecomputeLinksetCompound>b__2(BSPrimLinkable cPrim) in k:\OSGRID\opensim-fc9930e\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 377
   at OpenSim.Region.Physics.BulletSPlugin.BSLinkset.ForEachMember(ForEachMemberAction action) in k:\OSGRID\opensim-fc9930e\OpenSim\Region\Physics\BulletSPlugin\BSLinkset.cs:line 205
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.RecomputeLinksetCompound() in k:\OSGRID\opensim-fc9930e\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 356
   at OpenSim.Region.Physics.BulletSPlugin.BSLinksetCompound.<ScheduleRebuild>b__0() in k:\OSGRID\opensim-fc9930e\OpenSim\Region\Physics\BulletSPlugin\BSLinksetCompound.cs:line 112
   at OpenSim.Region.Physics.BulletSPlugin.BSScene.ProcessPostTaintTaints() in k:\OSGRID\opensim-fc9930e\OpenSim\Region\Physics\BulletSPlugin\BSScene.cs:line 1034
No tags attached.
Issue History
2014-02-20 03:24aiaustinNew Issue
2014-02-20 03:26aiaustinAdditional Information Updatedbug_revision_view_page.php?rev_id=2129#r2129
2014-02-20 03:37aiaustinNote Added: 0025235
2014-12-02 01:07aiaustinNote Added: 0027052

Notes
(0025235)
aiaustin   
2014-02-20 03:37   
If I remove OpenSim.ini [Map] RenderMeshes = true from my openSim.ini file the errors go way with r/24366

I am already using the replacement signed zlib.net.dll as suggested by JustinCC to fix earlier issues in the current master.
(0027052)
aiaustin   
2014-12-02 01:07   
Update: As at 1-Dec-2014 r/25590 on Windows 8.1 this error still shows up on most regions that use reasonably interesting meshes when using BulletSim physics and the Warp3D map tile rendering takes place... they are the current only source of red errors on Openvue and AiLand grids.

Failed to decode mesh assetComponentAce.Compression.Libs.zlib.ZStream
Exception: inflating:
   at ComponentAce.Compression.Libs.zlib.ZOutputStream.Write(Byte[] b1, Int32 of
f, Int32 len)
   at OpenMetaverse.Helpers.CopyStream(Stream input, Stream output)
   at OpenMetaverse.Helpers.ZDecompressOSD(Byte[] data)
   at OpenMetaverse.Assets.AssetMesh.Decode()