Mantis Bug Tracker

View Revisions: Issue #8512 All Revisions ] Back to Issue ]
Summary 0008512: runprebuild.bat will not detect VS 2019
Revision 2019-04-04 03:53 by mewtwo0641
Description I upgraded to Visual Studio 2019 and have discovered that runprebuild.bat will not detect the installation and will not generate compile.bat although it will generate OpenSim.sln and it can be opened and compiled from within VS.

Attached is a patch to fix this; Although I am unsure if the path for VS2019 is "correct" since I could not find MSBuild.exe following the similar path convention for 2017. It does generate the files and compiles fine via compile.bat though as far as I can tell.

The patch also fixes a minor issue where the generated compile.bat would have the msbuild command outside of the quotation marks like this "Path\To\MSBuild"\msbuild OpenSim.sln and it now generates with "Path\To\MSBuild\MSBuild.exe" OpenSim.sln
Revision 2019-04-02 20:47 by mewtwo0641
Description I upgraded to Visual Studio 2019 and have discovered that runprebuild.bat will not detect the installation and will not generate compile.bat or OpenSim.sln.

Attached is a patch to fix this; Although I am unsure if the path for VS2019 is "correct" since I could not find MSBuild.exe following the similar path convention for 2017. It does generate the files and compiles fine via compile.bat though as far as I can tell.

The patch also fixes a minor issue where the generated compile.bat would have the msbuild command outside of the quotation marks like this "Path\To\MSBuild"\msbuild OpenSim.sln and it now generates with "Path\To\MSBuild\MSBuild.exe" OpenSim.sln


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker