Mantis Bug Tracker

View Revisions: Issue #8455 All Revisions ] Back to Issue ]
Summary 0008455: Child agents not closed cleanly when HG traveller exits grid - closes only after 60000ms no packets received timeout
Revision 2019-01-16 07:24 by aiaustin
Description When a HG traveller left the grid and was (I believe) properly returned to their home grid, all the adjacent regions on two separate servers showed yellow messages after 5 minutes (60000ms) timeout... such as...

23:37:29 - [LLUDPSERVER]: No packets received from child agent of Brian.. @hg.viewtwo.net:8654 for 60000ms in Edinburgh Uplands. Disconnecting.

There have been changes to Dev Master in recent days in the area of child agent clean up for the teleport handling. However, the Git commits indicate that HG teleports are handled in the old way at present. It is possible this issue has been present for longer, but I am specifically monitoring teleport attempts due to the code changes and thought it worth opening this Mantis issue to allow inputs on any similar issues from those using Dev master versions after the [2019-01-14 17:25] commit.
Revision 2019-01-16 01:51 by aiaustin
Description When a HG traveller left the grid and was (I believe) properly returned to their home grid, all the adjacent regions on two separate servers showed yellow messages after 5 minutes (60000ms) timeout... such as...

23:37:29 - [LLUDPSERVER]: No packets received from child agent of Brian.. @hg.viewtwo.net:8654 for 60000ms in Edinburgh Uplands. Disconnecting.

There have been changes to Dev Master in recent days the area of child agent clean up for the teleport handling though HG teleports are handled in similar way at present the Git commits indicate. It is possible this issue has been present for longer, but I am specifically monitoring teleport attempts due to the code changes and thought it worth opening this Mantis issue to allow inputs on any similar issues for those using Dev master versions after the [2019-01-14 17:25] commit.
Revision 2019-01-16 01:47 by aiaustin
Description When a HG traveller left the grid and was (I believe) properly returned to their home grid, all the adjacent regions on two separate servers showed yellow messages after 5 minutes (60000ms) timeout... such as...

23:37:29 - [LLUDPSERVER]: No packets received from child agent of Brian.. @hg.viewtwo.net:8654 for 60000ms in Edinburgh Uplands. Disconnecting.

There have been changes to Dev Master in recent days the area of child agent clean up for the teleport handling though HG teleports are handled in similar way at present the Git commits indicate. It is possible this issue has been present for longer, but I am specifically monitoring teleport attempts due to the code changes and thought it worth opening this Mantis issue for thse using Dev master versions after the [2019-01-14 17:25] commit.
Revision 2019-01-16 01:46 by aiaustin
Description When a HG traveller left the grid and was (I believe) properly returned to their home grid. All the adjacent regions on two separate servers showed yellow messages after 5 minutes (60000ms) timeout... such as...

23:37:29 - [LLUDPSERVER]: No packets received from child agent of Brian.. @hg.viewtwo.net:8654 for 60000ms in Edinburgh Uplands. Disconnecting.

There have been changes to Dev Master in recent days the area of child agent clean up for the teleport handling though HG teleports are handled in similar way at present the Git commits indicate. It is possible this issue has been present for longer, but I am specifically monitoring teleport attempts due to the code changes and thought it worth opening this Mantis issue for thse using Dev master versions after the [2019-01-14 17:25] commit.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker