Mantis Bug Tracker

View Revisions: Issue #6530 All Revisions ] Back to Issue ]
Summary 0006530: Animations appear to not stop when being stopped via a list of UUIDs
Revision 2013-02-02 18:24 by mewtwo0641
Additional Information I have located where the issue first starts to show up; Commit b977f9 (r/20586). I also tested a couple of commits before it to be certain and in those commits the issue does not appear.

Have also noticed that while in step 4 (before playing an animation or walking) that if I stand still and play an animation from my inventory and then stop it, the avatar will appear to be frozen in that new animation until I move around or play a different animation.

I have placed some comments in the HUD script of some of my observations notably, stopping an animation via object inventory name appears to work while stopping via animation UUID does not. There's a few (noted) lines in the script that can be uncommented to test for this.

Tested using animations from here: http://www.lindakellie.com/Creations/LK-ANIMATIONS.zip [^] But it also happens with (as far as I can tell) all other animations.

During testing I am not using any scripted AOs (aside from the test HUD in animtest.iar) or the client side AO.
Revision 2013-02-02 18:18 by mewtwo0641
Additional Information I have located where the issue first starts to show up; Commit b977f9 (r/20586). I also tested a couple of commits before it to be certain and in those commits the issue does not appear.

Have also noticed that while in step 4 (before playing an animation or walking) that if I stand still and play an animation from my inventory and then stop it, the avatar will appear to be frozen in that new animation until I move around or play a different animation.

Tested using animations from here: http://www.lindakellie.com/Creations/LK-ANIMATIONS.zip [^] But it also happens with (as far as I can tell) all other animations.

During testing I am not using any scripted AOs (aside from the test HUD in animtest.iar) or the client side AO.
Revision 2013-02-02 18:16 by mewtwo0641
Additional Information I have located where the issue first starts to show up; Commit b977f9 (r/20586). I also tested a couple of commits before it to be certain and in those commits the issue does not appear.

Have also noticed that while in step 4 (before playing an animation or walking) that if I stand still and play an animation from my inventory and then stop it, the avatar will appear to be frozen in that new animation until I move around or play a different animation.

Tested using animations from here: http://www.lindakellie.com/Creations/LK-ANIMATIONS.zip [^] But it also happens with (as far as I can tell) all other animations.
Revision 2013-02-02 18:14 by mewtwo0641
Additional Information I have also noticed that while in step 4 (before playing an animation or walking) that if I stand still and play an animation from my inventory and then stop it, the avatar will appear to be frozen in that new animation until I move around or play a different animation.

I tested using animations from here: http://www.lindakellie.com/Creations/LK-ANIMATIONS.zip [^] But it also happens with (as far as I can tell) all other animations.


Copyright © 2000 - 2012 MantisBT Group
Powered by Mantis Bugtracker